Augie's Ring does not display

Installation and usage on Mac OS-X / Installation unter Mac OS-X
Post Reply
Alistair
Posts: 3
Joined: 18 Dec 2021 19:00

Augie's Ring does not display

Post by Alistair »

Hi Michael,
Heli-X10 is fantastic. A great SIM that keeps getting better!

I can not Show Augie's Ring. When I select it in the View menu nothing happens. It does not show and there is no blue dot beside the menu item to indicate that it should be active. It's like there is nothing attached to the menu item. (I can select Configure Instinctive Training Ring and make adjustments. But checking the ring active boxes does not display the ring either.). I am not sure if I am doing something wrong, or if there's a minor bug that can be easily fixed.

System. is MacBook Pro 2021, M1 Pro chip, 32GB RAM, MacOS 12.1. Heli-X v10.0.2465, Lib 2465, Resources 2465, LWJGL 3.3.0 build 8, JAVA 11.0.9.1, com.jme3.system.JmeVersion jMonkeyEngine 3.3.2-SNAPSHOT

Thank you again for an amazing SIM and a great learning tool.
User avatar
Michael
Posts: 1811
Joined: 25 May 2008 16:11
Location: Germany
Contact:

Re: Augie's Ring does not display

Post by Michael »

Hi,

1. Please play with the transparency
2. Switch it on and off again
3. Show us the contents of the terminal window if thee are error messages.
Alistair
Posts: 3
Joined: 18 Dec 2021 19:00

Re: Augie's Ring does not display

Post by Alistair »

Hi. I found a couple of things.

1. In the Ring configuration window, the ring is visible. But it is not centered on the Heli. So depending on how the sliders are set you might never see it. Even if I check the ring active boxes it does not stay displayed when I exit the configuration window. No errors in Terminal. Please see attached screenshot.

2. The menu item View > Show Augie's Ring appears to do nothing. It does not display the ring and no blue dot appears.

3. If I select View > Flight Path Configuration, the ring is displayed while the config window is open. But when the window is closed the ring disappears again. (The ring is always displayed when this configuration window is open. It does not change if I try to change the state of display ring from the View menu.)

4. If I select Exit Heli-X, the ring is displayed while the exit yes / no window is displayed.

(FYI the behavior of Show Position Pointer is also a little odd. The menu works. But sometimes the state of the pointer itself (on / off) does not match the state showed by the blue dot on the view menu. I can get it to work. But it's not quite right.)

I hope this helps.
Attachments
Ring Config 2022-01-23.jpg
Ring Config 2022-01-23.jpg (250.34 KiB) Viewed 1757 times
Alistair
Posts: 3
Joined: 18 Dec 2021 19:00

Re: Augie's Ring does not display

Post by Alistair »

Hi Michael! Yesterday I had to do a full removal of Heli-X from my Mac including user library files, and then reinstall. I did this because I had a problem with something else not important. With the fresh new install Augie's ring is now working perfectly, as is flight path and position. Awesome! :D
Post Reply